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Abstract

Visualization of simulation results from time and
frequency domain programs and measurement data from
a variety of monitoring systems is now available in a
personal computer-based (PC), graphical user interface
(GUI).  Waveform and tabular data from multiple
simulation programs and monitoring devices can be
displayed simultaneously.  Post processing of simulation
and measurement data using commonly needed
mathematical/statistical functions allows engineers to
easily integrate, compare, and visualize power system
data from several different sources.  This User's Guide
describes the Windows based output processor - TOP.
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I N T R O D U C T I O N

Getting Started

This introduction serves as a starting point for those users who are not
familiar with TOP, The Output Processor (hereafter referred to as
TOP).  The following sections provide an overview of the program
including the powerful main features which comprise TOP and how to
run them in coordination with other Windows Applications.

This chapter also describes in a step by step procedure, how to setup
TOP to run, including hardware and software requirements.  For
those users ready to start using TOP immediately, the final section in
this introduction is a quick tour of the program highlighting the
necessities as well as the most common applications for TOP.

In This Chapter

♦ What is TOP?
♦ TOP’s Program Structure
♦ TOP’s Data Capabilities
♦ What Programs/Monitors

Work with TOP?

♦ How to Use this Manual
♦ Installing the Software
♦ Using Microsoft Windows
♦ Quick Tour
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What is TOP?

TOP is an acronym for “The Output Processor” and is responsible for
the visualization of data from time and frequency domain solvers and
monitoring systems.  The Microsoft Windows operating environment
was chosen for TOP due to its popularity, GUI, multitasking ability,
ease of use, and inherent capability to facilitate data sharing between
applications.

TOP supports many different data formats including:

Ø COMTRADE (IEEE Std C37.111-1991)
Ø EPRI/DCG EMTP for OS/2 and Windows
Ø ATP (Alternative Transients Program)
Ø HARMFLO for Windows
Ø SuperHarm (HarmFlo+ Workstation)
Ø V-HARM
Ø Specific Measuring Devices

TOP has been designed using an open architecture to accommodate
additional data input filters.  The Windows Dynamic Link Library
(DLL) mechanism allows a third party to write a module that
translates data from a specific format into the format required by
TOP.  TOP requires a 80386, 80486 or Pentium based personal
computer using Microsoft Windows version 3.1 or greater.

TOP's Data Capabilities

This section will provide a detailed account of TOP’s main
methodology towards data handling.  The following processing
capabilities will be introduced:

Ø Data Management
Ø Data Display
Ø Data Processing
Ø Data Formatting
Ø Data Sharing

These capabilities will be discussed in detail in Chapters 1 - 4.
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Data Management Capability
TOP uses a method of data management called the stack to simplify
handling of data from various sources.  The stack holds the data
selected by the user from each source file.  This process is analogous to
selecting a file folder from a file cabinet, selecting specific papers in
the file that are of interest, and piling them in a stack on your desk.
The stack concept is described in Chapter 2 and is summarized as:

1. The user selects the file that contains the data to be displayed.

2. TOP then provides a dialog box which displays all of the quantities
available in the current file.

3. The user selects the items of interest which TOP loads into
memory.  The user may reactivate the dialog box at any time and
load more data objects onto the stack.  The user may also select
another file at any time and load data from that file onto the stack.
The result is a stack of data objects of different types and origins
that are available for display.

Data Display Capability
TOP provides a variety of ways to visualize the data of interest in the
form of tables and graphs.  Display options include:

Ø Waveform and Spectrum Plots
Ø Frequency Response Plots
Ø Summary Tables

Waveform Summary and Data Points
Frequency Domain Data
Harmonic Summary Data
Magnitude vs. Switch Operation
IEEE 519 Current Limits

Ø Summary Bar/Column Charts
Ø Cumulative Probability Charts
Ø Probability Density Charts
Ø Graphical Animation

TOP utilizes Microsoft's Multiple Document Interface (MDI) standard
to allow a user to view several different plots in multiple windows
simultaneously.  The user can move, size, and arrange the windows on
the screen as desired.  Any window can be printed with a simple menu
option.  In addition, TOP does not need to be updated every time a
new hardcopy device is installed.  This is due to the fact that
printer/plotter support is provided through the Windows environment.
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TOP uses windows and frames to display selected data.  Frames
include multiple sets of axes in one window.  One advantage of this
option is that measured and simulated data can be displayed in the
same window.  For printing, each window corresponds to a
(printed/plotted) page.

Data Processing Capability
A very useful post processing feature in TOP is called TOPCalc.  This
feature allows a user to perform mathematical operations on the
various data objects supported by the program.  Operations include:

Ø Addition, subtraction, multiplication, division
Ø Inversion, negate, absolute value
Ø Fast & discrete Fourier transformers (FFT, DFT)
Ø Inverse transform (IDFT)
Ø Power, energy and I2T
Ø Integration, square, square root
Ø X-Y combine
Ø Filter (high, low pass), time shift
Ø V, I, and power dB ratio
Ø Cumulative probability, probability distribution

This facility provides a means for creating new stack objects by
specifying mathematical operations to be performed on existing
objects.  Objects derived through TOPCalc are identical to raw data
loaded from input files  and can be used as arguments for subsequent
TOPCalc operations.  TOPCalc requires one or two arguments,
depending on the operation selected.  Argument #1 is always a stack
object.  Argument #2, if required, is usually an object, but may be a
constant.  Simple single argument operations include invert (1/X),
negate (-X), square (X2), square root (√X), and absolute value (|X|).
Mixed argument operations include addition, subtraction,
multiplication, division, power, energy, dB ratio, and X-Y combine.  In
addition, TOPCalc includes several sophisticated mathematical
operations.  The filter operation provides high pass, low pass, band
pass, and band reject options.  The FFT operation performs a Fast
Fourier Transform on the desired waveform.  The FFT operation
includes both single and sliding options as well as control over the
weighting function window.  The sliding FFT option is used to produce
a trend object of a single harmonic vs. time.
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Data Formatting Capability
TOP provides the capability to format the data display based on user
preferences.  Functions under user control include:

Ø Base quantities (per unitizing)
Ø Units (axis labels and multipliers i.e. kA)
Ø Data, comment, and annotation blocks
Ø Display colors
Ø Axis scaling, grid lines, labels

The Set Per-Unit Base Quantities option allows the user to control
scaling for each stack object individually.  This command may seem
redundant, given that TOPCalc allows division by a constant; however,
the effect is not the same because TOPCalc creates a new object while
base quantities acts directly upon the selected object.  This feature is
useful for displaying measured and simulated data on the same axis.

Another TOP function available to the user is the units command.
This option is used when the user needs to assign a different set of
units to the displayed object.  Although TOP automatically assigns
units to the X and Y variables of an object when it is created (load from
input file), there are instances when the user will need to change the
values.  An example of this is energy in an EMTP PL4 file.  Due the
structure of an EMTP output file, TOP assumes that the object is a
current and the user must change the Y axis display from “Current” to

When TOP loads a stack object it prepares information for a data
block.  The contents of the data block varies depending on the object
and input file type.  As an example, the data block for a simulated dc
drive harmonic spectrum would include the following information:

Freq: 60 (fundamental freq)
Fund: 293.9 (fundamental value)
THD: 35.2 (harmonic distortion)
RMSh: 103.5 (harmonic rms)
RMS: 311.6 (total rms)
ASUM: 455.1 (arithmetic sum)
TIF: 353.1 (telephone influence)

TOP also provides the user with the flexibility to control the display
colors, X and Y axis zooming (keyboard or mouse controlled),  tick
marks and grid lines, and axis labels.
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Data Sharing Capability
The data being visualized in a window can be exported to a variety of
other file formats, including:

Ø   Windows Metafile (.WMF)
Ø Comma Separated Variable (.CSV)
Ø IEEE COMTRADE (.CFG)

In addition, the Windows Clipboard can be used to transfer formatted
graphs to many other Windows applications.

What Programs / Monitors Work With TOP?

Small auxiliary programs, called data filters, allow TOP to read
various output files created by a number of simulation programs and
monitoring devices.  Which data filters are included with your version
of TOP depends on the filter option(s) that you purchased with the
program.

If your version of TOP is unable to read files from a program that it
should be able to support, check your TOP directory for the
appropriate data filter.  The data files can be found in the TOP
program directory with the .TDF (TOP Data File) extension.

How to Use This Manual

This User's Guide is divided into the following parts:

Introduction
This chapter contains an overview of the program.  A “quick tour” is
included for users who want to get started with TOP right away.

Using TOP
This chapter contains information pertaining to the usage and
configuration of the program.

Stack Management
This chapter discusses how to open simulation and measurement
program output files, and how to retrieve quantities of interest from
them.  It also covers how to per unitize quantities, and how to create
new quantities with TOPCalc.  All TOP users, beginning or advanced,
need to understand stack management operations - read this
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chapter in detail. A detailed section on the data filters available is
included here.

Working with Graphs
This chapter explains the various types of TOP displays, how to create
them, and how to manipulate them.  Beginners should become
comfortable with the Quick Graph option before moving on to the more
advanced options.

Working with Tables
Tabulating harmonic summaries, frequency scans, transient peak
magnitudes and other data is covered in this chapter.  Like the
advanced graphing options, new users can defer this topic.

Common Procedures
This chapter outlines in a step by step procedure common applications
performed in TOP.  This includes applications in TOP Calc as well as
using the New Graph feature.
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Installing the Software

Before you install TOP, insure that you have the proper equipment
and system software.  TOP is a Windows protected-mode application.
This requires Microsoft Windows version 3.1 or later, 80386, 80486, or
Pentium based machine.  80386 based machines must have a numeric
coprocessor (80387 or equivalent).

Your machine should be equipped with at least 4 Mbytes of memory.
Depending on how you use Windows, additional memory may be
required to achieve optimum performance.  Your graphics adapter,
printer, and pointing device (mouse) should be Windows compatible.

The full installation (including benchmark cases) of TOP will take
approximately 5 Mbytes of hard disk space.

Running SETUP
The following steps should be followed to install TOP:

1. Place the TOP setup disk #1 in one of your machine's floppy drives
(the following steps assume A drive).

2. Start Windows, if not already running, and open the Windows
Program Manager File Menu.

3. Select Run, then type A:\SETUP.  When prompted, select the
Continue button to begin the installation.

4. The Setup program prompts you to specify the drive and directory
in which to install TOP.  The default is C:\ETKPROG\TOP.  Select
OK to continue the installation.

5. When prompted, replace Setup disk #1 with disk #2.

6. This version of TOP installs all filters  when the program is first
installed.  There is no need to install any additional files.

7. The Setup program will create a new program group (Simulation
Tools) containing the TOP icon.
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Using Microsoft Windows

The following section provides an overview on the types of commands
available with the Windows workstation and how they can be applied
to TOP.  The different areas of features illustrated are:

Ø Menu Commands

Ø Dialog Box Commands

Ø Display Window Commands
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Operation

Menu Commands

Open a menu

menu
bar

Click the title on the
menu bar.  To click
an object means to
point to the object
using the mouse, then
rapidly press and
release the left mouse
button.

Press and hold the Alt
key, then press the
letter that is
underlined in the
title.  For example,
press Alt+F to open
the File menu.

Choose an item from a menu Click the item.

The three dots after
Preferences indicate
that more data is
needed.  If you select
the item, TOP will
display a dialog box so
that you can enter the
required information.

Use the ↓ key to move
to the item, then press
Enter↵.

 Or

Press the key for the
underlined letter in the
item name.  For
example, press C for
Copy.

Dialog Box Commands

A Typical
Dialog Box

L ist
B o x

R a d io
B u tto n s

B u tto n s

Text
B o x e s
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Operation

Dialog Box Commands, continued

Select a Button

F ramed But ton

Click the button Press Tab/Shift+Tab to
select (button becomes
framed), then press
Enter↵.

Or

Press the key for the
underlined letter in the
button name, if any.

Select/unselect an item in a list box Click the item to select
(becomes highlighted);
click highlighted item
to unselect.

The list box may or
may not allow more
than one item to be
selected.

· Press Tab/Shift+Tab
to move to the list.

 Or

 Press the key for the
underlined letter in
the check box name.

· Use ↑↓ keys to move
to desired item.

· Press spacebar to
select/unselect.

Select a radio button Click button to select
Click another button to
unselect.  (Radio button
options are mutually
exclusive - only one
button can be selected.)

· Press Tab/Shift+Tab
to move to the group.

· Use ↑↓ keys to move
to the desired button.

Or

Press the key for the
underlined letter in the
button name.

Set or clear a check box Click the box to set
(check) or clear
(uncheck).

· Press Tab/Shift+Tab
to move to the group.

· Use ↑↓ keys to move
to the check box.

· Press spacebar to set
or clear.

Or

Press the key for the
underlined letter in the
check box name.
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Operation

Dialog Box Commands, continued

Enter data in text box · Click box.

· Type/edit data.

· Press Tab/Shift+Tab
to move to group
containing text box.

· Use ↑↓ keys to move
to text box.

· Type/edit data.

Or

Press the key for the
underlined letter in the
text box name.

Use a combination
text/drop-down list box

SuperHarm Output

Select  Fi les of  Type:

Click text box to enter
data or click ↓ to open
list box.

· Press Tab/Shift+Tab
to move to text box.

· Type/edit data.

Or

· Press Alt+↓ to open
list box.

· Press Alt+↓/Alt+↑ to
move to item in list.

· Press spacebar to
select/unselect.

Display Window Commands

Open the Control menu
Control menu button

Click the control menu
button.

Press Alt+Hyphen.

Move a window Drag the window title
bar.  To drag an object
means to point to the
object, press and hold
the left button, point to
the desired location,
then release the button.

· Open Control menu.

· Select Move.  (Cursor
changes to four-
headed arrow.)

· Use ← ↑ → ↓ keys to
move window.

· Press Enter↵ to
confirm or Esc to
cancel.
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Operation

Display Window Commands, continued

Change window size Drag side frame to
change width.  Drag
top/bottom frame to
change height.  Drag
corner to change width
and height in same
proportion.

· Open Control menu.
· Select Size.  (Cursor

changes to four-
headed arrow.)

· Use ← ↑ → ↓ keys to
select frame.  (Cursor
changes to two-
headed arrow.)

· Use ← ↑ → ↓ keys to
move frame.

· Press Enter↵, or
cancel with Esc.

Maximize a window

Maximize but ton

Click Maximize button · Open Control menu.
· Select Maximize.

Return maximized window to original size

Restore
Button

TOP's control menu button
Display window's control menu button

Click Restore button. · Open Control menu.
· Select Restore.

Note:  When a display
window is maximized,
its control menu button
is located underneath
the TOP control menu
button, as shown.
Select the lower button.

Scroll through a table

Scroll
Bars

Scroll Up Button

Scroll Box ("Thumb")

Scroll Down Button

Click the appropriate
arrow to scroll up,
down or across.

· Click Scroll Up,
Scroll Down, Scroll
Left, or Scroll Right
button to move a line
or column at a time.

· To scroll several lines
or columns at once,
drag the appropriate
thumb, or click the
appropriate scroll bar
between the thumb
and the button of the
desired direction.
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Operation

Display Window Commands, continued

Minimize a window (to an icon)

Minimize button

Click Minimize button. · Open Control menu.

· Select Minimize.

Restore an icon to window Double-click desired
icon.  (To double click
an object means to
point to the object then
click the left button
twice in rapid
succession.)

· Use Ctrl+Tab to move
to desired icon.

· Open Control menu.

· Select Restore.

Make a window the active window*

D E R I V E D >    B U S B ( T y p e  1 )

Click on an exposed
part of window.  If no
part of window is
visible, use procedure
described for keyboard.

· Open Window menu

· Select title of window

* Although many windows can be displayed on the desktop, only one can receive commands - the
active window.  The active window is recognized on the desktop by its highlighted title bar, and in
the Window menu by a check mark beside the widow title.

Organize windows on the desktop · Open Window menu.

· Select Cascade (windows overlap) or Tile.

Close a window

Control menu button

Double-click Control
menu button.

· Open Control menu.

· Select Close.
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Quick Tour

The remainder of this introduction is a “quick” overview of the
fundamentals necessary to begin using TOP now.  The following
features are briefly introduced.

Ø Starting TOP

Ø Opening an Output File

Ø Placing Objects on the Stack

Ø Using TOPCalc

Ø Creating a Graph

Ø Getting Help

Ø Printing

Ø Closing TOP

More advanced features and details for each of the above subjects can
be seen in the following chapters.
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Starting TOP

If the TOP icon is visible on the Program Manager desktop.  (Arrangement varies; an
example of the desktop is shown below.)

• Double-click the TOP icon.  You can also start TOP from the programs that
support TOP directly (HarmFlo+ and  the EMTP for Windows workstation).  Start
the workstation by double-clicking its icon, then double-click the TOP icon in the
workstation window.

If the TOP icon is not visible on the Program Manager desktop:

• Use the keyboard procedure on the following page.
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Starting TOP, cont.
· Open the Program Manager File menu

· Select Run.  You are prompted for a program name:

· Type the full path name for TOP.EXE.  (It is not necessary to include the EXE
extension.)  Unless you specified otherwise when installing the EMTP for
Windows or HarmFlo+ workstation, the path will be c:\etkprog\top\top.exe.

·  Select the OK button.

Opening an Output File

· Open the File menu.

· Select Open.  The following dialog box is displayed:

Use the List Files of Type list box to select IEEE COMTRADE CFG Files

· Use the Drives and Directories list boxes to select the top\examples subdirectory
under the etkprog directory.

· In the list box under the File Name text box, double-click fdr25kv.cfg. If you do
not have a mouse, select this file in the list box, or type the file name in the text
box; then select OK.
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Placing Objects On The Stack

Now that the output file has been opened, you can retrieve node voltages, branch
currents, and other quantities contained in the file.  Quantities that you select are
placed in a holding queue called the stack.

Quantities that are obtained directly from an output file are called raw objects, as
distinguished from derived objects, which we will discuss in the next step.

After selecting OK in the File Open dialog box, TOP immediately displays the
Stack Load dialog box.  As illustrated below, each simulation and measurement
program supported by TOP has its own Stack Load dialog box.:

IEEE COMTRADE Dialog Box

· Select desired quantities from the Quantities list box.

· Select OK.
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Using TOP Calc

TOP Calc allows you to derive new stack objects by specifying mathematical
operations to be performed on existing stack objects.

Example 1

Given:  Measurements of Phase A and Phase B voltages.

Find:    Phase C voltage by adding  the Phase A and Phase B voltage

             waveforms and then negating the result.

· Open the Stack menu.

· Select TOP Calc.  The following dialog box is displayed:

· Select 1_A (WAVE) (phase A Voltage) as Argument #1

· Select the Curve option in the upper right corner of the TOPCalc dialog box.

· Select 3_A (WAVE) (phase B Voltage) as Argument #2

· Select Add in the Operations list box.

· Select the Do button to create the new object.
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Using TOP Calc, cont.

Note:  The new object is distinguished from the other objects in the list by the
DERIVED tag in its name

· Rename the DERIVED solution to a unique name at the Name fields. (PhaseC)

· Select Negate in the Operations list box.

· Select the Do button to create the new object.

· Select the Exit button to exit the dialog box.
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Creating a Graph

In this step, we will display a plot of our derived object.

· Open the Graph menu.

· Select Quick Graph.  The following dialog box is displayed:

· Select the derived object, (1_A)(PhaseC) in the list box as well as the Phase A
(1_A) and Phase B(3_A) waveforms.

· Select OK.

TOP opens a display window and creates the graph with all three phases overlaid.
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Getting Help

TOP supports the standard Windows help facility.  There are two ways to get help.

If a menu or dialog box is open:

· Press F1.  This opens the help index to the section covering the open menu or
dialog box.

Otherwise:

· Select the Help button on the ribbon:

or

· Open the Help menu.

· Select the desired topic.

To exit the help system, use the procedure described below for closing TOP.

· Press F1.

· Use Tab/Shift+Tab to select the desired topic, then press Enter↵.

To exit the help system, use the procedure described below for closing TOP.

Printing

There are several ways of printing TOP displays.  The method shown here is the
easiest - direct printing of a single display window.

· Open the File menu.

· Select Print Active.

Closing TOP

· Double click the Control menu button, or

· Open the Control menu and select Close, or

· Open the File menu and select Exit.

· Press Alt+F4, or

· Press Alt+Spacebar to open the Control menu, then select Close, or

· Open the File menu and select Exit.

Help, Index
Button
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